Sign in to follow this  
running free

Heads up

Recommended Posts

Just reading the am reception thread and made me remember, had the same problem on a 2006 Kia Amanti, Had to remove and replace the rear window, buuutt.. when I pulled the film off all the defrosters came off with it :drool .

This only happened once, so whern I have to do a re & re on a rear window I tell the custy I'm not responsible for damage do to the drefrosters coming off with the film :drool

:drool Has anyone else run into this mess?

Edited by running free

Share this post


Link to post
Guest haroldshouseoftint

check the vin#, I'll bet that car came from Canada ............................ :drool:lol2:lol2:drool

J/K, :drool

I've never had defrosters come off with the film, :lol2 can you elaborate more, do you mean they completly came off the glass, or you could see in the film where it was over the defrosters, and there was lines on the film once removed :drool

Share this post


Link to post
Guest darkdan

Some Llumar ATR CH took about 50% of each line off of 240 SX that I stripped. Made a nice black and orange pattern.

What's weird is I bagged it, then steamed it off, and it left behind no glue, yet took the lines with it.

Share this post


Link to post
check the vin#, I'll bet that car came from Canada ............................ :drool:lol2:lol2:lol2

J/K, :drool

I've never had defrosters come off with the film, :lol2 can you elaborate more, do you mean they completly came off the glass, or you could see in the film where it was over the defrosters, and there was lines on the film once removed :drool

Completely off, so much that I noticed it on the film I removed. Usually you can see the outline or trace of the defrosters but this time IT WAS the defrosters :lol2 It was that notcable. :drool

Share this post


Link to post
Guest haroldshouseoftint
:drool WOW, that's a new one, I've never seen that, unless I'm taking a 6" scraper to it :drool

Share this post


Link to post
:beer WOW, that's a new one, I've never seen that, unless I'm taking a 6" scraper to it :beer

Only happened once, like I always say there are no 2 windows exactly the same. :beer

Share this post


Link to post

I've had defrosters come off in spots here and there from film removal. the older the car the more likely it'll happen. a new car losing defrosters means it must be a kia. :beer

it happened to me a month or so ago on an 80s corvette. I warned the owner prior to removing the film though. it lost atleast 75% of the defrosters from the removal.

Share this post


Link to post
Guest Marco

Had an 80's Corvette this summer, it came from Florida nice work but the film was distorted right at eye level, it had a few brokens lines, not too bad but a 2000 Accord lost all it's lines, broken but not peeled off, more like cracks and chips in the lines :beer

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this