Sign in to follow this  
tinter101

Mercedes has a defroster issue

Recommended Posts

It has become very obvious that Mercedes has a batch of vehicles out there with defective defroster wires.

Let me clarify that. The wires may be completely intact and working but the problem occurs when anyone

touches the wires, such as cleaning the rear window, taping a temp tag to the glass or tinting process.

I believe that there is some final step to cure the wires to the glass during manufacturing that was skipped

or done wrong. The pic on the right below is a 2018 E class, we tinted the glass and then realizing that some of the wires

were messed up, we pulled the film back off the window while wet (2 min after install). All the wires came off the glass.

We sent the customer to the dealer and they replaced the window under warranty.

Yesterday we did a removal on a 2015 E class wagon and as we steamed the rear film off, many of the wires

simply pulled off with the film.

This morning as we were prepping a 2015 E class for tint we pulled the temp tag off the glass using our fingers

and the scotch tape pulled the defrost wires off. The second pic shows the temp tag from this morning, (look closely at the tape).

Clearly this should not happen and the fact that all have been E class Mercedes is telling.

temp tag defrost issue.JPG

mb issue.JPG

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this