Jump to content
Stek-USA

Xpel
“Stek-USA”

Xpel
Sign in to follow this  
NoRegrets

Silvery marks in 3m Ventureshield

Recommended Posts

Hi guys,

 

New in this forum, looking for a little bit of help!

 

I’m on learning installing PPF myself, I knew there’d be a lot to learn, so I’ve been reading quite a lot to get as much info as I could.

 

body panels were freshly painted about 6 months ago and it’s only driven back from the body shop.

 

Everything was wiped down to try and remove debris etc. Bottles made up for slip and tack to 3m’s description.

 

Thought i’d start with the hood with it being the flattest panel, I pre wet slipped the panel and then part peeled the PPF to wet the first part of the back and then laid that down, moving slowly over wetting the back as I unrolled across the hood - I’m pretty tall so I can stretch right over 😄

 

Anyway as a first effor it’s useless 😂 some parts have came out perfect but quite a few areas appear to have a silvery marks in, so my first question is any idea whats causing this and how to rectify on my next attempt?

 

my second question is to do with around the edges, I’d gone right upto the edges which weren’t fingering back, but I was having issues folding under due to moisture. Is it best to leave the areas for the moisture to evacuate? Or is it better to use the tack solution around the edges before beginning to squeege?

 

ive attached some pics for reference and thank any comment in advance!

DA0C0C82-0010-4995-8386-260502CFE656.jpeg

C1C68655-B86D-48D5-9BE8-4408A772B244.jpeg

F9798CE6-F209-436A-AC3A-0DC77BE9812D.jpeg

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×