Jump to content

Rear Defroster Came off!?!?


I_tint_TN

Recommended Posts

I have never seen the rear defroster come off with a removal. I trash bagged the back window like always, Using llumar atc, bg had a tiny hair in it said i would warranty just did the work a month ago. When i removed film almost all the glue came off, with the defroster! Why did this happen, is it the film? Please respond

Link to comment
I have never seen the rear defroster come off with a removal. I trash bagged the back window like always, Using llumar atc, bg had a tiny hair in it said i would warranty just did the work a month ago. When i removed film almost all the glue came off, with the defroster! Why did this happen, is it the film? Please respond

Never had this happen to me, but I've heard that some cars are prone to this happening. I guess just depends on the vehicle, but trust me, you're not the first person to have this happen.

Link to comment
I have never seen the rear defroster come off with a removal. I trash bagged the back window like always, Using llumar atc, bg had a tiny hair in it said i would warranty just did the work a month ago. When i removed film almost all the glue came off, with the defroster! Why did this happen, is it the film? Please respond

Never had this happen to me, but I've heard that some cars are prone to this happening. I guess just depends on the vehicle, but trust me, you're not the first person to have this happen.

it is an 08 is250 if this matters

Link to comment

Never seen it on a Lexus, but I had it happen one time on a KIA. This is why you ALWAYS let the customer know there is a chance this may happen, to cover yourself for a situation just like this.

Nothing you can do now but explain to the custy what happened and move on.

Link to comment
Guest tint325i

it just happens every now and again, for example i have stripped loads of vw's no problem, then one day i stripped a touran and the heater more or less came off in one piece, never seen it before or since, def not the film as i use atc myself and have removed it successfully many times, just bad luck I'm afraid

Link to comment

Sucks man. This happened to me on a chrysler and mercedes within a month of each other. Never seen it before then and kinda thought it was just a problem with Mercedes window since the Chrysler had the same glass. It is not your fault or the film, it is a defect in the defroster. Talk to Llumar, they may help you out with it. The Mercedes dealer replaced the glass under warranty. It is beneficial for them so maybe the Lexus dealer can help too

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...