suntekfilms
armolanusa.com
tintwiz.com
Xpel
spacer
suntekfilms
armolanusa.com
tintwiz.com
Xpel
spacer
Sign in to follow this  
John B

Contamination issue

Recommended Posts

Almost every car I do has little what people think are bubbles in the tint but it’s some sort of contamination. I clean the windows over and over I’ve tried a number of different cleaning methods. New spray bottle bottled water so on. Can anybody help me please. Thi is a huge problem 

 

Here’s what the film looked like after shrink before liner is removed so it’s on the outside of the film. This is after using bug scrubber sponge and squeegee. It actually went on fine but somehow it almost always ends up on the finished product. I haven’t been able to take a picture of that yet but I will. Any surface I put the film on is smooth and clean from plotter to glass board to vehicle. You can see the little dots in the lower pictures after install. 

800A6E0C-8521-4574-B76D-70120A214922.png

8C140E45-8E55-441C-9A90-8C5B83E58CB0.jpeg

E0F1B6A7-856F-42F1-A16C-F13796F43A7F.jpeg

Edited by John B
Add photo

Share this post


Link to post

Could be a number of issues, from your prep to the delivery on to the window. Shoot over some pics like DynamicATL said and go from there 👍

Share this post


Link to post

Environment, both the shop and the vehicle have a huge part.  The water you use, the film you use, the way you clean, the way you peel and handle the film, your personal hygiene and clothes cleaning practices can ALL play into small imperfections.....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this