Jump to content

Recommended Posts

Hey guys, I've recently been coming across issues of edges being lifting on clients cars. At the shop we have been heat sealing the edges with proper heat gun settings and also using tac solution to lock down the films. Me and partner are thinking 1) maybe the adhesive of the film is to weak (using Premium Shield), 2) or tac solution is either too strong or weak, 3) or maybe we should be using adhesive promoter on the edges.

Link to comment

My guess would be...

1. Over stretch at the edges

2. Not prepping with straight alcohol

3. Wax or ceramic coating on the surface

 

My prep work usually starts with a clay ball on the surface and pure alcohol before an install, followed by a pure water flush on the edges before trimming the excess film. A light bit of heat 20min later.

Link to comment
On 1/24/2022 at 10:01 AM, Dano said:

My guess would be...

1. Over stretch at the edges

2. Not prepping with straight alcohol

3. Wax or ceramic coating on the surface

 

My prep work usually starts with a clay ball on the surface and pure alcohol before an install, followed by a pure water flush on the edges before trimming the excess film. A light bit of heat 20min later.

We have been thoroughly prepping the car (clay bar, apc on the edges, etc), we still get minor finger towards the edges even after following tack points. Are minor fingers still a cause?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...